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1 Installation 
SMAP can be run either as a fully functional stand-alone version or within MATLAB. This 

information can also be found in the SMAP user guide. 

1.1 Installing the stand-alone version 
On www.rieslab.de scroll to Software and click on download compiled version for Windows 

and Mac. In the web page that opens you find a link to the installation guide: 
https://www.embl.de/download/ries/SMAPCompiled/Installation_notes_SMAP_compiled.rtf  

SMAP needs write access to its settings directory: 

• Mac: You need to grant write access to all files in 
/Applications/SMAP/application/settings and 
/Applications/SMAP/application/Documentation/pdf. For this, right-click the 
/Applications/SMAP directory, select Get info, select ‘Read & Write’ privilege for the 
current user (or everyone, if this doesn’t work, for current user and administrator), 
click on the lock symbol and enter the computer password to allow for changes, and 
below in the settings icon click ‘Apply to enclosed items’. 

• PC: Right-click on Program Files/SMAP/applications/ to show Properties. In the 
Security tab, allow full control to Users and ALL RESTRICTED APPLICATION 
PACKAGES. 

Finally, start SMAP from the task bar or application folder with a double click. In case of 
problems concerning access rights, please have a look at the trouble shooting guide in the 
installation notes. 

1.2 Installing the MATLAB version 
Requirements 
1. MATLAB 2019a and newer. Toolboxes: Optimization, Image processing, Curve fitting, 

Statistics and Machine Learning. 

http://www.rieslab.de/
http://www.rieslab.de/
https://www.embl.de/download/ries/SMAPCompiled/Installation_notes_SMAP_compiled.rtf
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2. Mac or Windows (Linux users will have to compile some C code into mex functions). 
3. For GPU fitting: Windows, NVIDIA graphics card. CUDA driver (recommended: version 7.5). 

All fitters also come with a CPU version that is used when these specifications are not met. 

Installation 
1. Clone git repository: 

a. Install git (https://git-scm.com/) if needed. Use Terminal (MacOS) or Cmd (Win). 
Use cd to navigate to the target directory. (e.g. cd git). 

b. Type: git clone https://github.com/jries/SMAP.git   
and type in your username and password for your git account. 

2. To start SMAP in MATLAB: run SMAP.m from the SMAP installation folder, if prompted, 
change folder. 

1.3 Installing third-party software 
1. As the simple example was acquired using Micromanager, install Micromanager 1.4.22 or 

later from https://micro-manager.org. 
2. In the Menu select SMAP/Preferences... Switch to the Directories tab and select the 

directory of Micro-Manager (main Micro-Manager directory, where you find the ij.jar, which 
however is not displayed in the file dialog on a PC). Press Save and exit. 

2 Preparation 
1. Download and unzip the example file 

Gettingstarted2D_Nup96-
AF647.zip from www.rieslab.de. For 
details on the sample see Box 1. 

2. You can select Menu/SMAP/hide 
advanced controls to have a simple GUI 
and hide advanced controls with default 
parameters. This guide is based on this 
simple GUI. 

3. If during the following protocol things don’t 
work as expected, try restarting SMAP. You 
can load the last *.sml file that was 
produced by clicking on Load in the File tab 
and selecting this file. 

3 Overview of the SMAP GUI 
This part is copied from the SMAP User 

Guide. After starting SMAP the SMAP GUI 
opens. Note that most elements in the GUI 
have a tool tip: hover with the mouse over the 
control to display it. Figure 1 shows the main 
parts of the GUI:  

1. Menu. There are three menu items: 

Box 1: The example sample.  

Nup96-SNAP labeled with BG-AlexaFluor647. Homozygous CRISPR cell lines, imaged 
in BME-based oxygen depleted imaging buffer as described in Thevathasan et al, Nature 
Methods 2019. This sample was acquired under very slow imaging conditions with 500 ms 
exposure time and an excitation intensity of 0.14 mW, leading to a high localization precision 
and a large number of re-activations. Images were acquired on a custom microscope using 
an sCMOS camera. 

Figure 1: Main parts of the SMAP GUI. 

https://git-scm.com/
https://github.com/jries/SMAP
https://micro-manager.org/
http://www.rieslab.de/
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a. SMAP: gives access to Preferences and the Camera Manager, allows saving and 
loading the GUI appearance, and allows toggling between a simple version of the 
GUI, in which optional parameters are hidden, and the advanced version of the GUI 
with all GUI elements shown. 

b. Plugins: here any plugin (except those that work only in the context of other plugins) 
can be called. 

c. Help: shows this documentation. 
d. Optional user-defined menus appear here as well. 

2. Overview/Filters. In this part of the GUI an overview image of the data is shown. Clicking 
on the image centers this part in the separate image window. Alternatively, this part of the 
GUI shows the filters that are applied to the localization data. The button OV -> filter toggles 
between these two modes. 

3. Render options. Controls in this panel relate to the rendered image (channels, 
magnification, user-defined ROIs). 

4. Plugin tabs. Each tab corresponds to a main task (loading/saving, fitting of single-
molecules, rendering, ROI manager) or a collection of user-defined plugins (post-
processing and analysis). 

5. Plugin GUI. The GUI of a specific plugin is shown here. 
6. Status bar. The status bar reports the progress. The execution of some plugins can be 

stopped using the Stop button. Some plugins change attributes of the single localizations. 
The Undo button can undo the last execution of such plugins. Pressing Undo a second time 
reapplies the changes. 

Many GUI components have tool tips defined, which are displayed when you hover the 
mouse over the component. Also, some lists or tab groups have a context menu attached 
(accessible by right-click). In most cases, the existence of a menu is denoted by a  =  symbol. 

Additional windows belong to the GUI:  

7. A figure window in which the rendered image is displayed 
8. Plugins called from the menu open their own GUI window 
9. The ROI manager has its own window. 

4 Fit SMLM data with a Gaussian PSF model 
1. After starting SMAP select the Localize tab. 
2. Check at the bottom of the Localize tab that the fitting workflow fit_fastsimple is 

selected. Otherwise load that workflow by pressing Change and selecting 
fit_fastsimple.txt.  

3. In the main SMAP GUI select the Localize/Input Image tab (Figure 2).  
4. Load images and select the tiff file 

Gettingstarted2D_Nup96-
AF647.tif that you just unpacked. 
Ignore an error from the Micro-manger 
loader that says you cannot load the 
image. If the file name appears in the 
field, it worked. 
The loader might display an error 
message that it cannot load the images. 
Ignore this for the moment and try the 
next steps. This error message comes 
from the micro-manager code; thus it 
cannot easily be fixed in SMAP. 

5. If you like, you can check the camera 
parameters with set Cam Parameters.  

6. In the Peak Finder you can set 
parameters for the candidate finding. 

Figure 2: The localization GUI 
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The cutoff parameter is an empirical relative parameter 
to distinguish background noise from real localizations. 
Select a value between 1.3 (very sensitive) to 3 (only fits 
clear localizations), for example 2.  

7. In the Fitter tab you can set fit options. For the fit with a 
symmetric Gaussian PSF of variable size (due to 
different z positions of the fluorophore with respect to the 
focus) select PSF free fit and a ROI size of 7 pixels. 

8. Select a large frame in the field next to the Preview 
button at the bottom of the GUI (e.g. frame 1000, as the 
first frames might be still too dense to optimize fitting 
parameters) and press Preview. A figure opens that 
shows the camera image and denotes with squares 
which regions are found as candidates for fitting. The 
results should be comparable to those in Figure 3. You 
can change the cutoff parameter to find more or less 
candidates.  

9. By changing the preview mode in the Peak Finder tab, you can select what image is shown. 
Either the filtered image, on which candidate finding is performed, or the original camera 
image.  

10. Press Localize and wait for the fitting to be done (this might take up to 20 minutes 
depending on your computer). The number of fitted localizations and frame, and the 
estimated time are shown continuously in the status text of the GUI. Note that this example 
file was reduced in size after acquisition for faster downloading, thus the number of frames 
(100 000) does not correspond to the number of frames SMAP extracts from the metadata 
(200 000).  

11. The fitting results are automatically saved in the directory of the camera data as 
Gettingstarted2D_Nup96-AF647_sml.mat. 

5 Render a superresolution image  
Here we discuss how to do a first superresolution rendering. In section 7 we will discuss 

additional render options to render the images according to the user’s preferences.  

1. Select the Render tab and press the Render button. A figure opens that shows the rendered 
superresolution image. 

2. Navigate in this image:  
a. Drag the image with your mouse. 
b. Right-click on a part of the image to center it. 
c. In the main GUI in the format panel press filter->OV to show the overview image. 

Click in this image to center the superresolution image to that part. 
d. Change the pixel size (zoom factor) by using the scroll functionality of your mouse. 
e. Alternatively set the pixel size in the main GUI in the format panel, either directly or 

.by pressing the  –  and  +  buttons, or the pre-defined pixel sizes. 
f. You can always reset the view to show all localizations by double clicking on the 

reconstructed image or by pressing Reset in the format panel. 

3. Zoom into the image to show only a few nuclear pores. You can change the number next 
to the contrast button to increase (e.g. to -3) or decrease (e.g. to -4) the brightness. Press 
the Render button to confirm the change. 

4. Under colormode select field and then in the new list select frame. Select the jet LUT below. 
Render. Now every localization is color coded by the frame they were detected in. You can 
clearly see a ‘rainbow effect’ with localizations at the upper left more blue and at the lower 
right more red. This indicates sample drift, which we need to correct for. See Figure 4.  

Figure 3: Preview allows you 
fine-tuning the peak-finding 
parameters. 
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6  Perform drift correction  
1. Reset view as described above, e.g. by double clicking on the image. Drift correction is 

performed only on the localizations that are rendered in the superresolution figure. 
Sometimes, it helps to filter the localizations before drift correction, as described in section 
7. However, the render parameters (Gauss vs histogram, pixel size, LUT color coding) do 
not have any effect on drift correction. 

2. Select the Process tab in the main GUI and then the Drift tab. Select the plugin drift 
correction X,Y,Z  by clicking on it.  

3. Make sure �Correct xy drift is selected.  

Figure 4: The render GUI and zoomed-in nuclear pores, color-coded by 
the frame, indicating drift.  

Figure 5: Drift correction: Left: redundant cross-correlations mostly overlap, 
indicating reasonable drift correction. Right: drift-corrected rendered image. 
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4. Select the number of time points (blocks) you want the data divided into for drift correction. 
The stronger and discontinuous the drift, the larger this number. But if the number of blocks 
gets too large, the pairwise distance estimation gets noisy and the accuracy suffers, 
especially for small fields of view with few defined structures. 10-50 is a good value. For 
this example with strong drift you can try 20 time points. 

5.  Click Run. The drift-corrected localizations are saved automatically with the ending 
*_driftc_sml.mat. 

6. Check if the majority of curves in the dxy/frame tab scatter without too much error around 
the black curve, this indicates that all redundant displacements are compatible with each 
other and that drift correction worked. You can Undo the drift correction, change the 
parameters and try again (Figure 5). 

7. Render the image and zoom in to appreciate that the nuclear pore complexes seem much 
better defined. 

7 Improve rendering and filtering of localizations 
Select the normal colormode and the red hot LUT. Now we will explore how different render 

and filter options change the appearance of the rendered image. After changing a parameter 
press Render to update the image. 

7.1 Basic render options 
Grouping: You can always toggle between showing all localizations in each frame 

(ungrouped) or showing the merged localizations that were obtained by grouping 
localizations that persist over several frames and belong to the same fluorophore and 
blinking event. Select and deselect �group to see the effect. Also note how that changes the 
number of displayed localizations (the number on top of the superresolution image). 

Contrast: Change the value to see how the brightness of the image changes. 
Renderer: Investigate the different render options, how Gauss vs constGauss with varying 

sizes for the Gaussian kernel and hist compare. We usually use Gauss. 
Colormode: As described before in section 5, you can explore different fields for color coding 

and different LUTs. 

7.2 Filtering of localizations 
It is a common practice to not display all localizations, but only a selected subset to improve 

the image quality. In SMAP, there are three (internally equivalent) ways of selecting filters for 
specific attributes of the localizations. Note that filtering is performed for every Layer 
separately. 

a. In the Layer tab you can directly access filters for localization precision in x,y and 
in z, PSF size, z range and frame. Insert the minimum and maximum value. Press 
the corresponding button, e.g. locprec. This will activate the filter. If the 
minimum/maximum fields are grayed out, the attribute is not filtered, if it is white, 
the attribute is filtered. 

b. With the OV->filter button in the format panel you can toggle between showing the 
overview image or advanced filter options. On the left, on top you see a list of all 
attributes. Here you can set a check mark for filtering, and edit the minimum and 
maximum values (min set, max set). The checkbox �inv for invert lets you invert 
the specific filter. This is a useful option to directly see what localization are rejected 
by the filter. 

c. By pressing a button belonging to a localization attribute in the Layer tab or by 
selecting an attribute in the table, you select this attribute in the histogram below. 
The histogram in green is a histogram of the value for all localizations. The red 
curve is a histogram only for the filtered and displayed localizations. The sliders 
below allow you to select the minimum and maximum range. If �auto update is 
selected, any change directly causes the image to be rendered. You can check �fix 



 7 

range to a value specified below, then if you change the minimum or maximum, the 
maximum or minimum are changed automatically, respectively. 

Important attributes for filtering: 
locprec: Localization precision in x,y in nanometers. This filters out dim localizations with a 

poor precision (e.g. worse than 30 nm), increasing the effective resolution of the 
superresolution image at the expense of localization density. Note that even if this filter is not 
used, there is a filtering on the number of photons and thus localization precision that comes 
from the peak detection step. As very dim fluorophores are not detected, they are already 
filtered out then. 

locprecz: as above, but for z-coordinates. 
zrange: z-range to display only a slice in z. 
PSF xy: Size of the PSF when using a Gaussian fit. This allows rejecting fluorophores that are 

out-of-focus and thus blurred, leading to effective sectioning of the image. 
frame: The frame in which the localization was first detected. Remove early frames if the 

localization density in the beginning was very high. Remove late frames if most fluorophores 
have been bleached already and these frames contain mostly background localizations. 

Ch (channel or color): This is for multi-color data sets where each localization has an attribute 
channel that denotes the color.  

LLrel: relative log-likelihood. This is a measure for the goodness of fit and can be used to 
reject poorly fitted localizations that mostly stem from overlapping fluorophores. A suitable 
value cuts off the long tail at negative values but leaves most of the peak in. 

 
Several analysis plugins calculate additional localization fields. For example, the count 

neighbors plugin counts the number of neighbors of each localization within a specific radius 
and writes this number as a field. You can then use these filter options to only display 
localizations within a structure, i.e. with a sufficient number of neighbors. 

7.3 Advanced render options 
Show the advanced GUI options by clicking v in the top right corner of the Layer tab and 

explore the following render parameters: 

render par: This opens a dialog box in which you can set parameters that are specific for the 
selected renderer. For the Gauss renderer you can select the minimum size of the Gaussian 
in pixels and nanometers and the proportionality factor between the localization precision 

Figure 6: Effect of filtering and rendering parameters. Left: ungrouped, unfiltered data. 
Right: grouped and filtered data, rendered with the intensity normalization √photons. 
Scale bar 1 µm. 
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and the size of the Gauss. The gamma factor of the image can be set here as well, but we 
recommend leaving it at 1. 

Intensity coding: Here you can select how the Gaussians for rendering are normalized. The 
integral over the Gaussian is: normal: 1; photons: the number of photons in the localization; 
blinks: the number of merged localizations in that constitute a specific localization, use only 
for displaying grouped data; √photons: square root of photons and √blinks: square root of 
merged localizations. These normalizes the noise, as due to Poisson statistics the standard 
deviation of photons per localization is given by √photons. And it can be a good compromise 
between normalizing according to photons and blinks and standard normal normalization. 

Renderer: Try out the DL (diffraction-limited) renderer to render an image as it would look like 
if taken with a diffraction limited microscope and raw to display some raw camera frames. 
The raw image with the number 0 corresponds to the average of all camera frames.  

7.4 Reconstruction in multiple layers 
You can reconstruct data with different rendering parameters in different layers and overlay 

the reconstructions. Most importantly, this is used for multi-color data. But it can also be useful 
to compare different render modalities. 

As an example, we describe here how to render a superresolution image and to overlay it 
with a diffraction-limited reconstruction (Figure 7). 

1. Render your superresolution image as described above. 
2. Click on the + tab next to the Layer1 tab. This opens a new tab called Layer2.  
3. In this tab select the DL renderer and the gray LUT and press Render. The composite 

image is rendered. 
4. You can hide or show specific layers by a) the 

check boxes in the format GUI (top right in the 
main GUI) or b) by clicking the left top checkmark 
in the Layer tab. 

5. You can rename the Layers by right-clicking next 
to the tab and select rename layer.  

6. In the format GUI you can check �label to 
display the label names in the reconstructed 
image. With �split you can show images 
corresponding to each layer next to each other. 
With check �comp you can additionally render 
the composite image. 

7. Explore different reconstruction options by 
comparing them directly using this feature (see 
Figure 6). 

8. If you like, you can save the reconstructed image 
as a tiff file by selecting the File tab. Then next 
to the Save button select TifSaver and press 
Save.  

8 Perform simple analyses 
Here we discuss a few simple analysis routines. For more information, consult the User 

Guide. You can also search for specific plugins for a given task in the Help/Search plugin 
menu. Consult the help files with detailed description by pressing the info button. Get 
information about the GUI parameters from the tool tips by hovering with the mouse above 
them. 

Figure 7: Overlay of diffraction-limited 
and superresolution rendering using 
two layers. 
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8.1 ROIs 
SMAP allows the user to draw ROIs in the reconstructed image. Many plugins then only 

evaluate localizations inside the ROI.  

Measuring distances: The Line ROI is also useful to quickly measure distances in the image. 
Click the line icon in the format GUI and draw a line in the reconstructed image. The length 
of the line is displayed next to it. You can then drag the end points of the line to change the 
ROI (Figure 8). 

Selecting Localizations: You can select localizations with the line ROI, then specify the width 
of the line ROI next to the icon.  

8.2 Fitting intensity profiles with Gaussian functions 
Select the Analyze tab. In this, select the measure tab. Select Line profiles. As a model, 

select Distance, then a double Gaussian will be fitted to the profile. Use the line profile to draw 
a line through two clusters in one nuclear pore complex. The ROI should extend beyond the 
clusters. Select a small line width on the order of the cluster size (e.g. 20 nm). Press Run. In 
the yprofile tab you see the line profile (as a histogram of localizations along the line ROI) and 
a fit with a double Gaussian. The FWHM is the distance from the first to the last data point that 
is above half the maximum value of the profile. More useful are the distance (in nm) and the 
width of the Gaussians, given by their standard deviation (Figure 8).  

8.3 Statistics on localizations 
Delete the line ROI. You can either zoom into the region you want to analyze or draw a larger 

ROI, e.g. a rectangular ROI. In the measure tab select Statistics and the default parameters, 
press Run. The individual tabs of the resulting figure show histograms and statistics on various 
parameters, such as the photons per localization, the localization precision, the on-time of the 
fluorophores in frames and the background. 

8.4 FRC resolution 
In the measure tab you can also select FRC resolution. Execute with default parameters 

with Run. The FRC resolution curve with the resolution estimate is shown. 

8.5 Color code according to density  
In the tab Analyze, cluster select the plugin density calculator. Run it with default 

parameters. This might take a while. This plugin creates a new attribute for the localizations 
called clusterdensity (in reality it is the number of neighbors). In the Render tab you can select 
it for color coding by selecting field as colormode and clusterdensity as the field to use for 
color coding. Use e.g. the jet LUT. 

Figure 8: Left: line ROI tool to manually measure distances. Center, right: line-ROI tool 
to define line profiles, that can be fitted with the plugin: Line profiles. Scale bar 100 nm. 
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Select the advanced GUI options with the v button on the top right of the Layer GUI. Click 
on c range. Use the sliders under the histogram to adjust the color range that is mapped to the 
number of neighbors.  

8.6 Versatile renderer 
This plugin allows plotting any localization attribute vs any other and can be found in the 

Analyze, other tab. We will illustrate this by plotting the coordinate of the localizations for a 
single nuclear pore vs the frame to see when individual fluorophores were activated. Color 
coding is according to the same field as chosen in the Render, Layer tab. 

1. Select a single nuclear pore with a circular ROI or by zooming into the image until only one 
nuclear pore is shown. 

2. For the horizontal axis select frame (even if it is already selected). 
3. For the vertical axis select xnm. 
4. Run. 
5. You can adjust the parameters, e.g. the pixel size and the blurring of the image (given in 

sigma of the pixels). 
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