Analysis of NPCs using SMAP
This manual relates to the publication:

Thevathasan, Kahnwald et al, “Nuclear pores as versatile reference standards for quantitative superresolution
microscopy”, bioRxiv (2019), doi: https://doi.org/10.1101/582668. Contact: Jonas Ries (ries@embl.de).

1 Installation of SMAP
1.1

Requirements
1.

MATLAB newer than 2016a. Toolboxes: Optimization, Image processing, Curve fitting, Statistics and
Machine Learning. Optional: Parallel Computing. A stand-alone version will be released, but will be
limited in extensibility.
2. Mac or Windows
3. For GPU fitting: Windows, NVIDIA graphics card. CUDA driver (recommended: version 7.5).

1.2

Installation
1. Clone git repository:
a.
b.

2.
3.

Use Terminal (MacOS) or Cmd (Win). Use cd to navigate to the target directory. (e.g. cd git)
Type:
> git clone https://github.com/jries/SMAP
and type in your username and password for your git account.
c. Install the 3D fitter by typing
> git clone https://github.com/jries/fit3Dcspline
Follow the instructions in SMAP/Documentation/Manual/SMAPStep-by-StepGuide.md
To use the version of the software that was used for the bioRxiv paper type:
> git checkout NPCbiorxiv

2 Fitting of raw data in SMAP
2.1

Fitting of single-color 2D data
1.
2.
3.
4.
5.
6.
7.
8.
9.

2.2

Go to the [Localize] tab.
If not set already, choose the workflow fit_fastsimple by clicking on Change.
In the [Input Image] tab click on load images and select your raw data tiff file (the first one in case it is
a large stack or the frames are saved as individual images.
In case the acquisition is still running, click the check box for Online analysis.
Switch to the [Fitter] tab and choose the “PSF free” fitter from the drop-down menu.
Switch to the [Peak Finder] tab and choose the threshold algorithm for the peak finding from the
drop-down menu. Typically, we use “dynamic (factor)” with a value of 1.5.
Change the preview mode to “norm(image)” and click on Preview. A window will open which shows
the detected peaks and their fitted coordinates.
Click on Localize to start the fitting.
Once all the raw data is fitted, a *.mat file containing the fitted positions and all associated
information is automatically saved.

Fitting of dual-color data and assignment of colors
1.
2.

Fit the data as described above.
After the file with the fitted coordinates has been saved, create a transformation of the 2 channels
onto one another:
a) Go to [Process] -> [Register] -> Register Localizations.
b) Change the target to the area of the camera that you want to transform (in our case this is
bottom).
c) Choose the appropriate mirroring modality (in our case this is up-down).
d) Possibly you need to adjust the Parameters. After a click a window with more options opens.
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When clicking on Run, a first image is rendered using the first pixelsize from the parameters
window and cross-correlated according to itself according to the target and mirroring modality
and the max shift matching.
f) The resulting transformation is internally stored and used as starting parameter for a second
iteration with the second values for pixelsize and max shift matching.
g) Inspect the figures of the opened results window and check that the cross-correlation converged
to the correct maximum. If there was no proper convergence, try increasing the values for “Max
shift for correlation (nm)” and “Max shift matching (nm)”.
h) Save the transformation by clicking on save T.
3. Get the intensities for the 2 channels:
a) Go to [Process] -> [Assign2C] -> 2C intensities from images.
b) Click on load tif to load the raw data.
c) Click on load T to load the transformation generated in the previous step.
d) Check only the tick box for roi2int_fitG
e) Adjust the parameters as follows:
roisize: 7
☐ Fix PSF (pix) size to
☐ fit on BG
f) Click on Run
This will add new values for each localization to the localization table
4. Assign the localizations to the different color channels:
a) Got to [Process] -> [Assign2C] -> Intensity2Channel
b) Choose the newly assigned values fit_n1 and fit_n2 as value 1 and value 2, respectively.
c) Click on Run and check the resulting point clouds.
d) Adjust the values for the slope, the edges and the offset of the separation to separate the 2 colors
as good as possible.
5. To display the 2 different channels, go to the [Render] tab and add a layer by clicking on [+]
Change the Channel (Ch) to 2 and change the LUT to a different one than used in Layer1 and click on
Reconstruct.
e)

2.3

Generation of a calibration file for 3D data

For details please refer to: Li, Y., Mund, M., Hoess, P., Deschamps, J., Matti, U., Nijmeijer, B., Sabinina, V.J.,
Ellenberg, J., Schoen, I., and Ries, J. (2018). Real-time 3D single-molecule localization using experimental point
spread functions. Nature Methods 15, 367–369.
1.

2.
3.

4.

Acquire z-stacks of 10 – 20 different FOV of beads with the following settings:
• z-range: -1 µm – 1 µm
• ∆z = 10 nm (also higher values like 20 or 50 nm can be used for faster acquisition)
• single-mode excitation (to prevent d)
• acquisition in conventional gain (to increase the signal to noise ratio)
Launch the calibrator from SMAP via [Analyze] -> [sr3D] -> [calibrate3DsplinePSF] -> Run
In the new GUI, open the acquired bead stacks by clicking on Select camera files
Load the files via add (for individual files) or add dir (for folders containing the individual acquisitions)
and click on Done
The output file is automatically set but can be adjusted as desired (Select output file)
Use the following (default) General parameters:
• 3D modality: arbitrary (this works for any PSF engineering modality)
• Distance between frames (nm): 10 nm (the value you took as ∆z when acquiring the bead
stacks)
• Correct bead z-positions using: cross-correlation
• frames to use for CC: 50 (this takes the central 50 frames for cross-correlation)
• Filter size for peak finding: 2
• Relative cutoff: 1
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Minimum distance (pixels): 25 (This option discards beads that are too close to each other in
the maximum intensity projection)
5. Use the following (default) Cspline parameters:
• ROI size: X,Y (pixels): 27
• Smoothing parameter in Z: 1
6. Under Spatially resolved calibration you can
7. Tick the box for EM gain used (mirrored) in case you acquired the bead stacks with EM gain (this
affects the mirroring of the reconstructed data later)
8. After clicking on Calculate bead calibration the PSF calibration starts a new window with results
figures opens that gets continuously filled with more information
9. The different tabs of the results figure contain the following information:
• [Files]: Overview over the maximum intensity projections of the individual stacks.
• [PSFz]: Profile of the PSF along z
• [PSFx]: Profile of the PSF along x
• [PSF]: Slice viewer of the PSF
• [validate]: frame against fitted z for every bead; the range with a linear relationship between
the 2 can be used for 3D
10. Files with the endings “_3dcal.mat” (calibration file) and “_3dcal.fig” (figure of the results) are
automatically saved
•

2.4

Fitting of single-color 3D data
1.
2.
3.
4.
5.
6.

2.5

Do the first 4 steps as described for 2D data
Switch to the [Fitter] tab and choose the “Spline” fitter from the drop-down menu.
Load the calibration file (*_3dcal.mat) generated previously by clicking on Load 3D cal
Click the check box labeled “New pixelsize X,Y (um)” and put in the values for your setup in µm.
Click the check box labeled “RI mismatch” and put the value for your setup. In our case, we found 0.8
to be a good value.
Continue from step 6 on as for single-color 2D data

Drift correction
1.
2.

3.

2.6

Go to [Process] -> [Drift] -> drift correction X,Y,Z
The following parameters are important:
• timepoints for xy-drift: The number of timepoints the superresolved image is split into for
cross-correlation
• pixrec nm for xy-drift: Pixelsize for the reconstructed images
• Tick the box for Correct z-drift if you are working with 3D data.
• Timepoints z and z binwidth nm are analogous to above mentioned values
• Tick the box in front of Save driftcorrected SML to automatically save a new file after drift
correction
Click on Run and evaluate the quality of the drift-correction in the window with figures that
automatically opened.

Rendering of localizations

Before segmentation and analysis, the image must be filtered to exclude incorrect localizations. This is achieved
by setting boundaries for the parameters localization precision, PSF size, frames and likelihood. Furthermore,
the colormode is changed to redshift localizations with a large PSF size, potentially corresponding to out-offocus localizations.
1.

2.
3.
4.

In the table at the top of SMAP, select the likelihood-filter LLrel. Set the filter to exclude the
accumulation of localizations (shown as a green bar) on the left side of the histogram.
a. If an overview of the image is shown instead of the table, click OV->filter.
Activate the LLrel-filter by checking filter
Go to [Render].
In Filter fields, set locprec, PSF xy, frame as shown in Table 1 for the corresponding sample.
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5.
6.
7.
8.

Change Colormode to field and PSFxnm.
Change LUT to jet.
Change contrast to -2.5
Click Reconstruct.

Table 1: Suggested rendering parameters for dyes/FP.
Dye/FP
AF647, Cy5, CF680
PA-JF549/646
mMaple

locprec [nm]
0-10
0-10
0-25

PSF xy [nm]
0-150
0-150
0-150

frame
1000-inf
0-inf
0-inf

3 Segmentation of NPCs with ROI manager
The ROI manager can be accessed in the [ROIs] -> [Settings] -> show ROI manager.
It shows an overview of the measured fields of view, a list and picture of segmented ROIs, as well as their
coordinates and important parameters (average PSF size, number of localizations, …).
[Settings] sets parameters for the visual representation in the ROI manager. Typical parameters are:
pixelsize (nm) FoV (nm)
ROI (nm)
dz (nm)
Site 3
400
220
1000
Cell 15
5000
Imax for sites can be set to 0.1 to get the same brightness for all localizations shown in the ROI manager.
[Evaluate] scans localizations in ROIs using different plugins. To do so, plugins can be added with add module.
Plugins needed for commonly used applications (calculation of ELE, counting parameters and automatic
segmentation) are NPCLabelingQuantify_s, NPCsegmentCleanup, countingStatistics and generalStatistics.
[Segment] uses plugins to segment the loaded file based on different features. New plugins can be added to
the list by rightclick -> add plugin.
[Analyze] covers plugins which calculate and display the absolute ELE, geometry, counting statistics and photon
statistics.
Many segment or analysis plugins can be also found in the main [Analyze]-[NPC] tab.

3.1

Segmentation of NPCs

The filtered and drift corrected superresolution image can be segmented for NPC manually or automatically.
1. Automatic segmentation
a. Open the ROI manager.
b. Run the makeCellGrid plugin in [Segment].
c. Redraw all in [Settings].
d. Run the segmentNPC plugin in [Segment]. Typical parameters for NPC segmentation are
cutoff: 0.06, diameterNPC: 100, rim: 20. Check the box saveon before running the plugin. If
only a part of the image should be segmented, additionally check getmask.
e. In [Evaluate] check only NPCsegmentCleanup. For NPCsegmentCleanup standard parameters
are suitable in most cases. However, max average PSF can be set to 140 to further exclude
out of focus localizations.
f. Run the plugin by checking evaluate on (display can be unchecked to increase processing
speed) and a click on redraw all. This step can take several minutes.
g. Switch to the ROI manager and click update above the list of ROIs. ROIs which were
unsuccessful during the NPCsegmentCleanup quality check will be shown with a – at their
end.
h. In [Helper] set the 1st sort to descent. Following that, choose Annotation in the drop-down
menu. A list opens upon clicking select. Set list1->value and start with Run. This step sorts the
list of ROIs in the ROI manager based upon the results of the quality check through the
NPCsegmentCleanup plugin.
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In the ROI manger, select all ROI names with a – at their end and delete them with Remove or
the delete key.
Manual segmentation
a. Follow steps a-d of the automatic segmentation.
b. In the ROI manager, go through the list of ROIs (up/down keys) and decide if the shown
picture corresponds to an in-focus NPC, unspecific binding or aggregation. ROIs which clearly
resemble background localizations, aberrant shapes or overlapping/out-of-focus (redshifted
according to colormode set in 2.6) NPCs are removed by the delete key or Remove button in
ROI manager.
c. Follow step j from the automatic segmentation process.
i.

2.

4 Analysis in SMAP
4.1

Analysis of profiles
1.
2.
3.
4.
5.

4.2

Go to [Analyze]->[measure].
In ROI (right side of SMAP) choose line roi. The width [nm] of the line profile can be changed next to
the symbol.
Draw the line in the image window across your region of interest.
Click select the plugin Line profiles and start with Run.
A window with results opens.

Analysis of dye photophysics
1.
2.
3.
4.

4.3

Go to [Analyze]->[measure].
Select Statistics. By default, the plugin evaluates only localizations currently depicted in the field of
view in SMAP. To change this, uncheck use Roi.
Start the plugin by Run.
A window opens, showing various photon statistics. Additionally, results of the plugin are
automatically saved to the clipboard to paste it into a spreadsheet.

Fourier Ring Correlation (FRC) resolution

According to: Nieuwenhuizen, R.P.J., Lidke, K.A., Bates, M., Puig, D.L., Grünwald, D., Stallinga, S., and Rieger, B.
(2013). Measuring image resolution in optical nanoscopy. Nat Methods 10, 557–562.
1.
2.
3.
4.

4.4

Got to [Analyze]->[measure], select the plugin FRC resolution
Choose if to use all localizations or only those currently displayed
Choose additional parameters (for details see publication above)
A window opens with the result of the FRC analysis

Geometric analysis
1.
2.
3.

In [ROIs]-[Evaluate] uncheck NPCsegmentCleanup and add module NPCgeometryQuantify.
Give an estimate for the radius of the NPC and specify what range around the circle is considered
valid.
redraw all.

After running the NPCgeometryQuantify plugin, you can show all results with the [Analyze]-[NPC]
NPCgeometry plugin.

4.5

Effective Labeling efficiency

In [ROIs]-[Evaluate] uncheck NPCsegmentCleanup and check generalStatistics
Use [add module] to add the two plugins NPCLabelingQuantify_s and (for counting experiments)
countingStatistics. Additionally, activate Use circular ROI under generalStatistics. Run the plugins by
redraw all. This step can take several minutes.
After running the NPCLabelingQuantify_s plugin, the calculation of the absolute effective labeling efficiency can
be done via an [Analyze] plugin.
1.
2.

3.

Go to [Analyze]->[NPC].
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4.
5.

4.6

Select NPCLabelingEfficiency. Standard parameters are optimized for evaluation of Nup96 ELE. Start
the plugin by Run.
A window opens after the plugin is finished. The ELE can be seen, among other important parameters
(average PSF size, average localizations per NPC, NPC size) in the tab [corners]. Additionally, results of
the plugin are automatically saved to the clipboard to paste it into a spreadsheet.

Counting

Counting parameters can be calculated after the plugin countingStatistics is run. To do so,
1.
2.
3.
4.
5.

In the [ROIs]-[Evaluate] add the countingStatistics plugin and redraw all.
Go to [Analyze]->[NPC].
Select histogram from Roimanager. For mMaple-based counting studies parameters shown in Figure 1
were used.
Start the plugin with Run.
A window opens, showing results of the counting statistics. Most importantly, the mean localizations
per ROI can be seen in [histogram]. Additionally, results of the plugin are automatically saved to the
clipboard to paste it into a spreadsheet.

Figure 1 Used parameters in the histogram from Roimanager plugin when analyzing mMaple-based counting
studies.

4.7

Simulations
1.
2.
3.
4.

Restart SMAP to make sure no data is loaded.
Select [ROIs]-[Segment] SimulateSites.
Select the parameters for your simulation (see ToolTip help for each parameter) and Run the plugin.
All simulated nuclear pores are added to the ROImanager and can be used for any analysis.

5 Analysis scripts outside SMAP
5.1

Analysis of ring-diameters in images

This function was used to quantify the diameter of rings in the Ex-SIM experiment (Figure 1, Supplementary
Figure 2) to calculate the local expansion factor.
1.
2.
3.

Run the script (with add to path)
SMAP/other/fitCircleImg.m
Select a Tiff file. If the pixel size is not recognized from the Tiff metadata, you can define it yourself
after line 19.
In line 47 you can select the width (sigma) of the Gaussian used for blurring. If you set it to empty
(sigmafix=[]) the width is used as a free fitting parameter.

4.

Zoom into the image until you can easily identify nuclear pores
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5.

6.

5.2

Use the data cursor to select centers of individual nuclear pores. These get marked in the image. An
additional window opens that displays the image, the starting model, the fitted model and the
residuals.
To display the histogram of all radii type in the console: fitCircleImg(1)

Counting in diffraction-limited microscopy

This function is used to generate a histogram of local maxima of an image stack.
1.
2.
3.
4.
5.

Set parameters (description in the file).
Start the script SMAP/other/countNupsDL_confocal.m from the SMAP directory (‘add to path’ when
asked).
Select tiff file or tiff stack.
If required select freehand ROI.
The results are displayed in a figure.
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